Technology Blogs

1 minute reading time (131 words)

Configuring Mikrotik Router as client VPN for routing all internal traffic to external VPN Server for specific websites

Scenario

You have a VPN Server installed outside of your Mikrotik Local Area Network. The VPN Server can be in your premises or outside premises. You have a username and password for connecting to that external VPN Server thorugh your laptop or desktop. To avoid providing username and password to all local area network users you want to create VPN client in Mikrotik router through a username and password that you use to connect on your computer to route all Mikrotik LAN Users to connect to specific website using that particular VPN connection. Here are the configuration steps:

 

/interface pptp-client
add add-default-route=yes connect-to=IP Address of VPN Server disabled=no name="External VPN" \
    password=password user=username

/ip firewall nat
add action=masquerade chain=srcnat out-interface="External VPN" src-address=\
    192.168.2.0/24

Where 192.168.2.0/24 is your Mikrotik LAN Network.

Mikrotik Router VoIP Skype QoS Prioritization Best...
Overview of Pakistan Power Sector and Key Challeng...
 

Comments

No comments made yet. Be the first to submit a comment
Guest
Sunday, 16 December 2018

Captcha Image

Wait a minute, while we are rendering the calendar

Have some questions before website development?

logo-bottom.png

Search